• New Feature
  • Status: Closed
  • 2 Major
  • Resolution: Fixed
  • adahanne
  • Reporter: alexsnaps
  • March 29, 2012
  • 0
  • Watchers: 2
  • July 27, 2012
  • May 02, 2012


On 2012-03-28, at 8:21 PM, Tim Eck wrote:

I don’t think you’re soliciting design for that feature at the moment, but since it came up I think it would probably be a good idea to have the default/automatic annotation name pattern contain both something like “ehcache” and “IgnoreSizeOf”. Of course google is telling me that IgnoreSizeOf look likes a term specific to ehcache at the moment

On Thursday, March 29, 2012 5:38 AM, Alex Snaps wrote:

I was indeed thinking of honouring any @IgnoreSizeOf annotation, regardless of its package. Now we could have the *.ehcache.IgnoreSizeOf or something. That very one would actually not include ours (net.sf.ehcache.pool.sizeof.annotations.IgnoreSizeOf)… Not really a big deal. One other open question is whether we’d want to support “extensions” to the annotation in both variances (currently only inherited defaulting to false, but who knows what the future might bring). I’d, right now, argue for no… Thoughts ?


Tim Eck 2012-03-29

I don’t feel super strongly on this point, but I was thinking that the pattern would be more like {noformat}”*ehcache*IgnoreSizeOf*”{noformat} or something. Just to avoid any possible unintended cross talk with an IgnoreSizeOf that was not for ehcache purposes.

Anthony Dahanne Dahanne 2012-05-02

see code review summary : http://svn.terracotta.org/fisheye/cru/CR-504