• Bug
  • Status: Closed
  • 2 Major
  • Resolution: Won't Fix
  • amiller
  • Reporter: tgautier
  • May 05, 2008
  • 0
  • Watchers: 1
  • May 21, 2008
  • May 05, 2008

Description

Exception in thread “main” java.lang.NullPointerException at com.tc.bundles.OSGiToMaven.artifactIdFromSymbolicName(OSGiToMaven.java:15) at com.tc.bundles.OSGiToMaven.makeBundleFilename(OSGiToMaven.java:42) at com.tc.bundles.OSGiToMaven.makeBundleFilename(OSGiToMaven.java:38) at com.tc.bundles.exception.MissingBundleException.getSummary(MissingBundleException.java:80) at com.tc.plugins.ModulesLoader.initModules(ModulesLoader.java:105) at com.tc.object.tools.BootJarTool.(BootJarTool.java:231) at com.tc.object.tools.BootJarTool.main(BootJarTool.java:2525) bash-3.00# pwd /visualvm-pod/terracotta/terracotta-2.6-stable4/samples/pojo/jtable bash-3.00#

Comments

Taylor Gautier 2008-05-05

SunOS U45-Sol10 5.10 Generic_127111-11 sun4u sparc SUNW,A70

Taylor Gautier 2008-05-05

seems to be on both 1.6 and 1.5: java version “1.5.0_15” Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_15-b04) Java HotSpot(TM) Server VM (build 1.5.0_15-b04, mixed mode)

java version “1.6.0_06” Java(TM) SE Runtime Environment (build 1.6.0_06-b02) Java HotSpot(TM) Server VM (build 10.0-b22, mixed mode)

Taylor Gautier 2008-05-05

seems to be coming from make-boot jar tool:

Exception in thread “main” java.lang.NullPointerException at com.tc.bundles.OSGiToMaven.artifactIdFromSymbolicName(OSGiToMaven.java:15) at com.tc.bundles.OSGiToMaven.makeBundleFilename(OSGiToMaven.java:42) at com.tc.bundles.OSGiToMaven.makeBundleFilename(OSGiToMaven.java:38) at com.tc.bundles.exception.MissingBundleException.getSummary(MissingBundleException.java:80) at com.tc.plugins.ModulesLoader.initModules(ModulesLoader.java:105) at com.tc.object.tools.BootJarTool.(BootJarTool.java:231) at com.tc.object.tools.BootJarTool.main(BootJarTool.java:2525)

Hung Huynh 2008-05-05

Can’t reproduce with dev08 (Solaris 10), jdk hotspot1.5.0_12

[[email protected]:jtable]$ run.sh 2008-05-05 09:53:13,593 INFO - Terracotta 2.6-stable4, as of 20080430-140453 (Revision 8422 by [email protected] from 2.6) 2008-05-05 09:53:14,970 INFO - Configuration loaded from the file at ‘/export1/dev/hhuynh/terracotta-2.6-stable4/samples/pojo/jtable/./tc-config.xml’. Creating boot JAR at ‘/export1/dev/hhuynh/terracotta-2.6-stable4/samples/pojo/jtable/./../../../lib/dso-boot/dso-boot-hotspot_solaris_150_12.jar… Successfully created boot JAR file at ‘/export1/dev/hhuynh/terracotta-2.6-stable4/samples/pojo/jtable/./../../../lib/dso-boot/dso-boot-hotspot_solaris_150_12.jar’. 2008-05-05 09:53:39,330 INFO - Terracotta 2.6-stable4, as of 20080430-140453 (Revision 8422 by [email protected] from 2.6) 2008-05-05 09:53:40,923 INFO - Configuration loaded from the file at ‘/export1/dev/hhuynh/terracotta-2.6-stable4/samples/pojo/jtable/./tc-config.xml’. 2008-05-05 09:53:41,652 INFO - Log file: ‘/export1/dev/hhuynh/terracotta-2.6-stable4/samples/pojo/jtable/terracotta/client-logs/pojo/jtable/20080505095341526/terracotta-client.log’. 2008-05-05 09:53:56,146 INFO - Statistics buffer: ‘/export1/dev/hhuynh/terracotta-2.6-stable4/samples/pojo/jtable/terracotta/client-statistics/pojo/jtable/20080505095355058’.

Taylor Gautier 2008-05-05

Tried with Terracotta 2.5.4, got this error:

bash-3.00# bin/make-boot-jar.sh 2008-05-05 09:55:42,786 INFO - Terracotta 2.5.4, as of 20080328-160336 (Revision 7748 by [email protected] from 2.5) 2008-05-05 09:55:43,547 INFO - Configuration loaded from the Java resource at ‘/com/tc/config/schema/setup/default-config.xml’, relative to class com.tc.config.schema.setup.StandardXMLFileConfigurationCreator. 2008-05-05 09:55:44,262 FATAL - Unable to locate bundle dependency: ‘jdk15-preinst-config’, version ‘2.5.4’, group-id ‘org.terracotta.modules’; Tried to resolve the location using the following repositories: ‘/terracotta/terracotta-2.5.4/modules’

Alex Miller 2008-05-05

talking to Taylor - looks like the jdk15-preinst-config module jar file name was garbled after untar so couldn’t be found. We’ll track that in a separate jira.

Let’s focus this one on fixing the npe in error reporting for a missing default module. Seems like the symbolic name is null which is causing the npe during error reporting.

I’m not sure if we need to handle the null (it’s already handled for all user-supplied modules upstream) in OSGIToMaven or if we should be passing a name for a miss in loading one of the default modules.

Hung Huynh 2008-05-05

You could have run into a corrupt install if you use “tar” on Solaris. It is broken and doesn’t untar files correctly. Take a look at your modules folder to see any filename truncation.

Could you try “gtar” instead? It’s usually installed under /usr/sfw/bin

Alex Miller 2008-05-05

Talked to Taylor and he confirmed that it was tar problem and that gtar fixed it.

Fiona OShea 2008-05-05

I’ve added a “Known Issue” to the release notes