• Bug
  • Status: Closed
  • 1 Critical
  • Resolution: Fixed
  • hhuynh
  • Reporter: hhuynh
  • September 29, 2007
  • 0
  • Watchers: 0
  • October 12, 2007
  • October 08, 2007

Description

This is the error I got running with TC Maven plugin:

[INFO] [bootjar] 2007-09-29 11:45:19,207 ERROR - [email protected] [INFO] [bootjar] 2007-09-29 11:45:19,208 FATAL - Unable to locate bundle: ‘excludes-config’, version ‘1.0.0’, group-id ‘org.terracotta.modules’; Tried to resolve the location using the following repositories: ‘file:/C:/Users/hhuynh/.m2/repository/;file:/C:/Users/hhuynh/.m2/repository/;’ - unable to initialize modules, shutting down. See log for details.

Comments

Eugene Kuleshov 2007-09-29

I think this is heavily related to CDV-435 or even duplicating it. The problem is that tcbuild deploys module jars as *-1.0.0-SNAPSHOT.jar so there is no *-1.0.0.jar to resolve, even so tc.properties refers to *-1.0.0.jar.

My current workaround is to rename all module jars in local Maven repository to *-1.0.0.jar

Juris Galang 2007-10-08

The work done on the Resolver, solved half of this issue. I’ve updated the plugin to take those changes into account.