• Bug
  • Status: Closed
  • 2 Major
  • Resolution: Fixed
  • hhuynh
  • Reporter: tgautier
  • September 22, 2007
  • 0
  • Watchers: 0
  • October 29, 2007
  • October 15, 2007


I believe Gary has been tracking this one, but I got it too.

I tried to run a “virgin” setup of the jetty webcast. I cleaned my m2 repository to get everything refreshed. Here is what I ran into:

[INFO] [bootjar] 2007-09-22 14:00:08,870 INFO - Configuration loaded from the file at ‘/Users/tgautier/src/forge/projects/labs/webcasts/jetty/target/classes/tc-config.xml’. [INFO] [bootjar] Exception in thread “main” java.lang.RuntimeException: Unable to create runtime for plugins [INFO] [bootjar] at com.tc.plugins.ModulesLoader.initModules(ModulesLoader.java:106) [INFO] [bootjar] at com.tc.object.tools.BootJarTool.(BootJarTool.java:202) [INFO] [bootjar] at com.tc.object.tools.BootJarTool.main(BootJarTool.java:2291) [INFO] [bootjar] Caused by: java.lang.NullPointerException [INFO] [bootjar] at com.tc.bundles.KnopflerfishOSGi.startBundle(KnopflerfishOSGi.java:70) [INFO] [bootjar] at com.tc.bundles.KnopflerfishOSGi.startBundles(KnopflerfishOSGi.java:64) [INFO] [bootjar] at com.tc.plugins.ModulesLoader.initModules(ModulesLoader.java:159) [INFO] [bootjar] at com.tc.plugins.ModulesLoader.initModules(ModulesLoader.java:89) [INFO] [bootjar] ... 2 more [INFO] OK [INFO] Skipping starting DSO Server


Taylor Gautier 2007-10-15


Juris Galang 2007-10-15

this is no longer an issue. the jetty webcast project was referring to ver 0.0.4 of the tc-maven-plugin.