• Bug
  • Status: Closed
  • 2 Major
  • Resolution: Won't Fix
  • foshea
  • Reporter:
  • May 27, 2009
  • 0
  • Watchers: 0
  • July 27, 2012
  • June 23, 2009

Description

I think this might be a duplicate of another bug I filed, but it’s still not fixed.

orion-macbook:examinator-1.1.1 orion$ export TC_INSTALL_DIR=/usr/local/terracotta orion-macbook:examinator-1.1.1 orion$ bin/startCluster.sh Starting web server on port 8080 Terracotta enabled: true Starting BootJarTool… 2009-05-27 10:34:04,113 INFO - Terracotta 3.0.1, as of 20090514-130552 (Revision 12704 by [email protected] from 3.0) 2009-05-27 10:34:04,547 INFO - Configuration loaded from the file at ‘/Users/orion/work/examinator-1.1.1/tc-config.xml’. Creating boot JAR at ‘/usr/local/terracotta/lib/dso-boot/dso-boot-hotspot_osx_150_16.jar… Successfully created boot JAR file at ‘/usr/local/terracotta/lib/dso-boot/dso-boot-hotspot_osx_150_16.jar’. JETTY_HOME is not found Failed to start web server at port 8080

Comments

Hung Huynh 2009-05-27

JETTY_HOME is set automatically so it seems something doesn’t work right on OSX. It works fine on Windows and Linux.

Could you add “set -x” at the beginning of startNode.sh and paste the output here?

Fiona OShea 2009-05-27

See CDV-1156 for the original which was marked not reproducible. I'm guess here that w tried to reproduce it on Linux. Mac is not a “supported” platform.

Fiona OShea 2009-05-29

Fiona: Create a related doc issue.

orion 2009-06-24

Ah. It looks like I have JETTY_HOME automatically set by my startup scripts to a directory that doesn’t exist. Unsetting JETTY_HOME solves the problem. But, it’s still a potential gotcha that we ought to document.